Navigation menu

Download Yosemite from the App Store. Sign in using your Apple ID. Yosemite is free. The file is quite large, over 5 GBs, so allow some time to download. It would be preferable to use Ethernet because it is nearly four times faster than wireless. Macs that can be upgraded to OS X Yosemite. To find the model identifier open System Profiler in the Utilities folder.

1 Answer from the Community

It's displayed in the panel on the right. Communities Contact Support. Sign in.

Archived from the original on April 16, Retrieved April 13, Minimize windows to App icon and Expose". June 27, Retrieved August 29, Archived from the original on July 22, June 19, Archived from the original on December 7, Mac — Printing". April 29, Archived from the original on August 4, Retrieved August 21, November 13, Retrieved November 16, September 6, Retrieved March 17, Archived from the original on November 12, Macs that use the bit kernel".

Retrieved September 6, Starting up with the bit or bit kernel". August 27, Archived from the original on December 5, Mac OS X Internals: The Blog. The New York Times.

Mac OS X 10.6

Archived from the original on January 11, Archived from the original on September 4, Getting Closure with Objective-C". Archived from the original on Archived from the original PDF on June 12, Ars Technical. Archived from the original on May 9, Printer Working Group. Archived from the original on August 15, Retrieved June 5, Archived from the original on September 16, Retrieved September 15, The Unofficial List". Archived from the original on June 2, Retrieved June 21, About incompatible software". November 25, Archived from the original on February 1, Retrieved December 29, Printer and scanner software".

Archived from the original on July 18, February 4, Archived from the original on July 7, Archived from the original on May 22, Archived from the original on May 29, Ipv6-dev Mailing list.

Will Snow Leopard work on MacBook Early 2008? I'd hate to buy this and find out it doesn't work.

June 24, Archived from the original on August 3, Retrieved April 22, Archived from the original on April 22, Archived from the original on June 22, Apple's Snow Leopard sports subtle improvements". Archived from the original on June 29, Archived from the original on June 18, Archived from the original on October 31, Archived from the original on June 5, June 26, BBC News. October 13, November 9, June 9, Retrieved January 10, What to Expect in Apple's Snow Leopard".

PC Magazine. Retrieved May 26, Archived from the original on January 9, About This Mac "build" information". April 14, Archived from the original on May 24, Retrieved April 26, Archived from the original on November 14, Retrieved November 9, Image credit: While Apple boasts about the extremely high percentage of iPhone, iPad, and iPod touch devices that are rapidly upgraded to each major new version of iOS, such is not necessarily the case with Macs and OS X.

That's not terrible given that it's been out for less than a month.

Get your Mac ready for OS X El Capitan | Macworld

This makes non-upgraded Macs a potentially significant target for criminals interested in infecting large numbers of computers. Anyone still using Lion, Snow Leopard, or an earlier version of Mac OS X should strongly consider upgrading to Yosemite if their Mac supports it, or if not, they should buy new hardware if they can afford it. Let's face it, that's what Apple wants you to do anyway. But what can you do if Yosemite is not supported on your Mac and you can't afford to buy a new computer? If you have an older Intel Mac, you have several options.

While Apple may not support your Mac anymore, ironically Microsoft does; Windows 8. Oddly enough, even Windows 10 Technical Preview's system requirements hint that Windows 10 will probably run on your old Intel Mac. Microsoft's skipping the name "Windows 9," by the way. Alternatively, if you can't afford to buy a copy of Windows, or aren't interested in risking all your data to a pre-beta operating system, or just can't stand the thought of running Windows on your Mac—or if you prefer to support free and open-source software—there are guides online detailing how to install Ubuntu Linux on a Mac.

The latest versions of Ubuntu are even still being made available for PowerPC-based Macs , including those with a G3 processor. At the time of this writing, Another option is, of course, to buy a cheap PC, tablet, or Chromebook, assuming it will do all the things for which you personally need a computer. Be forewarned: The average Mac user probably won't be excited about any of those options. I suspect that most Mac users, geeks and non-geeks alike, would rather buy a newer Mac than switch to another platform altogether. If you can't afford to buy a brand new Mac but you do have a little bit of money to spend, you can shop around for used Macs, but make sure you buy one that's new enough to support Yosemite so it will hopefully be able to get security updates for a couple more years.

If you know a Mac user who's still running an older version of OS X , do them a favor and check to see whether their Mac is capable of running Yosemite. If so, help them upgrade. If not, let them know it's time to strongly consider getting a newer computer.

The burden of informing users about software and hardware that will no longer receive security updates should really fall on Apple—not on security researchers, security blogs, or blog readers. Let's hope Apple eventually figures this out and starts giving users clearer notifications when they need to upgrade lest they put their digital safety at risk. It's highly unlikely that Mac OS X v Thanks for the great, informative article Joshua.

Quad-core 3. And just like other articles say as well. I would greatly appreciate any feedback. Your system is no longer supported. It is a Xeon based on the Core 2 Quad lineup. Your processor supports 64 Bit Operating systems but the firmware under it is 32bit. Google a guide and start reading. Michael, you can install Yosemite on your machine but it will require some workarounds.

Living With Mac OS X 10.6 Snow Leopard for 1 Week in 2018

Do a search for pikes yosemite installer and you will be fine as long as you can follow the instructions. Good luck!

All replies

I am still using snow leopard Was wondering why there were plenty of spinning beach-balls on safari, and google messages of no longer supporting this browser. Starting to get concerned , but not realising the lack of support.

${translate.overlay.error.header}

That is pretty shocking, not to mention downright stupid , and thoughtless behaviour from Apple.. I use linux on a separate machine already. You can get newer versions of firefox and chrome for these old versions of OS X. Odd that they would quit supporting old hardware, though, really.

Oh well, sticking with I think the article is spot on in that they keep itunes updated because they have a financial incentive to do so. And your point further exemplifies that. I have a MBP mid , I recently installed Yosemite but it does not seem to work, it would show a progress bar that does not complete and the mbp does not boot to its desktop. What can I do? Leave it going, first boot it is doing some crazy disk check, yes it looks like the machine has crashed. Try leaving it overnight. My Lion is still useful for running my printer and scanner in my private network.

So I have a iMac. I am having issues with it not wanting to update to Yosemite nor does it want to update my Publisher Plus application. Thanks for the post; it really helped me understand what is happening with support for my laptop, a mid Macbook. I guess its time to face the future and retire the trusty little black Macbook.

Ironically, right now it dual boots windows 8. If your seven-plus year old Mac is still useful, OK, keep using it.

All docs, apps and settings come over seamlessly. You should not mislead people into thinking their older incompatible applications will move over to new OS platforms and hardware that is not necessarily compatible. Many 3rd party apps will have to be upgrades as will programs like Disk Warrior for the 64 bit environments.